carmudgeons.com  

Go Back   carmudgeons.com > Automotive Forums > Going Faster

Reply
 
Thread Tools Display Modes
Old 12-12-2018, 04:03 PM   #121
kognito
older fart than ZBB
 
kognito's Avatar
 
Join Date: Oct 2003
Location: On the road again
Posts: 7,207
This thread is awesome!!!!
__________________
2017 GMC Sierra 1500 SLE
2016 Focus SE
kognito is offline   Reply With Quote
Old 12-12-2018, 04:05 PM   #122
BahnBaum
Tilting Rocinante
 
BahnBaum's Avatar
 
Join Date: Jun 2004
Location: Havre de Grace, MD
Posts: 6,156
me 3
__________________
BahnBaum is offline   Reply With Quote
Old 12-12-2018, 04:22 PM   #123
Josh (PA)
Hello.
 
Josh (PA)'s Avatar
 
Join Date: Mar 2004
Carmudgeonly Ride: '03 325xiT, '11 135i C, '13 X5 n55
Location: Downingtown, PA
Posts: 3,240
in and enjoying it.
__________________
Josh (PA) -
'11 135i convertible
'13 X5 n55
'03 325 wagon
Josh (PA) is offline   Reply With Quote
Old 12-12-2018, 05:04 PM   #124
equ
Alphanumeric
 
equ's Avatar
 
Join Date: Aug 2005
Carmudgeonly Ride: 981S, 535i, macanurbo
Posts: 7,973
I'm following. Awesome stuff...
equ is offline   Reply With Quote
Old 12-12-2018, 06:04 PM   #125
GimpyMcFarlan
Confused
 
Join Date: Oct 2003
Carmudgeonly Ride: 2013 X3 Gray/Mojave
Location: Columbus, OH
Posts: 765
Love reading these update!
__________________
Gimpy McFarlan
2013 X3 28i: Space Gray / Mojave & Black - Premium Package - Cold Weather Package - Dynamic Handling Package - M Sport Package - Convenience Package - 3M Paint Protection
GimpyMcFarlan is offline   Reply With Quote
Old 12-31-2018, 04:30 PM   #126
John V
No more BMWs
 
John V's Avatar
 
Join Date: Apr 2005
Carmudgeonly Ride: 987S, Ram, MS3, CX-5, RX-8
Location: Glenwood, MD
Posts: 12,529
I made some progress over the holidays. Because I can't seem to be bothered to take pictures of incremental progress, some of this isn't really well documented.

Engine is back in for the (hopefully) last time before I turn the key for the first time. I made a battery mount, finished all the battery wiring, and powered up the car. Everything works, the fuel pump primes and builds pressure, no leaks that I can see or smell. I finished up the oil plumbing, though I may shorten one hose. Sensors are in place for fuel pressure, oil pressure and oil temp to connect to the (eventual) aftermarket EFI. The DBW throttle even works without the engine running, which may be of use if I go with a Megasquirt ... could use the stock ECU to do the throttle and the Megasquirt for everything else. Not sure.

Mostly I spent a bunch of time cutting and fitting intercooler pipes until I was happy. I wanted to minimize the number of silicone couplers in the intake tract so I had a buddy TIG weld it all together for me.



The piping is a lot easier to manage without all the couplers everywhere.





I got the clutch fitted, reinstalled the transmission and finally got to install the driveshaft that arrived months ago. Everything fit together as expected. I bled the clutch and tested its travel... it seems to fully release but it's definitely close to the floor. I may need to modify the factory clutch pedal, or at least just adjust the plunger to get a little more release, but I won't know until I can start it and test the driveline with the engine running. It's already been reinforced as I guess it's pretty common for them to break.



I didn't like the way the Fab9 kit had the oil drain at the block set up. They call for you to drill and tap the block in an area between two internal strengthening ribs. The problem with this is the block casting is angled there, so it's very hard to thread in the (3/8 NPT) fitting they want you to use. And the hose to the turbo is so short it's a pain to install. And everyone seems to have issues with it leaking. I saw this stripping out pretty quickly, so I turned an AN fitting to TIG weld into the block, now installing and removing the turbo oil drain is easy.





Not much to do before I can turn the key. I managed to booger up the one O-ring I had for the (Ranger) dipstick tube at the (custom) oil pan, and nothing I have in my stock will work. I need to make a plug for the stock dipstick tube (in the valve cover) since I'm not using that with this pan. I need to figure out the hot side radiator hose connection, now that the intercooler piping is done I can work that out, plus one more hose for the overflow and another one for the heater core return. Oh, and there's no exhaust, just a dump pipe off of the turbo. So, that's gonna be loud.
John V is offline   Reply With Quote
Old 01-06-2019, 06:27 PM   #127
John V
No more BMWs
 
John V's Avatar
 
Join Date: Apr 2005
Carmudgeonly Ride: 987S, Ram, MS3, CX-5, RX-8
Location: Glenwood, MD
Posts: 12,529
Getting there... it's a bunch of small stuff now that needs to get wrapped up. And a couple big things - engine management, tuning and aero. But it's complete enough that I put it on the scales to see where things stand.

2526lbs is not bad. Interior is complete less the driver's seat, which is 8lbs. Exterior is missing the front and rear aero. I estimated the wing and uprights at 25lbs and the splitter at 10, but I really don't know. The splitter will probably be closer to 5lbs with brackets and struts. There's no muffler or piping. I weighed a spare 3" muffler I had laying around with a section of pipe that is about the right length and it was 15lbs. It's probably two gallons down on fuel, so 12lbs.

That puts it at 2591, which is only a couple pounds over the minimum, so I'll probably need 20lbs of ballast, which is not a bad thing.

Just waiting on my factory computer to get back from having the immobilizer removed and I can fire it up... or try at least.





John V is offline   Reply With Quote
Old 01-19-2019, 04:21 PM   #128
John V
No more BMWs
 
John V's Avatar
 
Join Date: Apr 2005
Carmudgeonly Ride: 987S, Ram, MS3, CX-5, RX-8
Location: Glenwood, MD
Posts: 12,529
Deep annoyance overtook me when I got my ECU back ... and the immobilizer was still active. Long story short, there was a new release of the tuning software that the shop uses and the update flipped the polarity of the immobilizer. So basically the guy got my ECU, coded it for an active immobilizer, and sent it back. He is sending me one of his test ECUs that he verified works, so I should be able to try to start it soon. Still... annoying.

Still lots to get done anyway. I got started on making the rear upper shock mounts. I got this idea from Tamra and Drew, and used the same spherical bearings they did. This eliminates the factory rubber donut mounts for the rear shock shafts. I shortened the housings by a couple inches as well to get the desired bump / droop numbers relative to static ride height.

Factory rear shock hat:



Top cut off:



New top plate mocked up, with the hole for the bearing cup cut out:





Not my prettiest welding, but whatever.



I turned some simple pieces to adapt the 0.550" Penske shafts to the spherical bearing. I know people say the Grizzly mini-lathes are useless but if I can whip stuff like this up in an hour, it's totally worth having.



Next job I've been putting off is re-making the lower front crossmember. This piece braces the back of the subframe to the unibody and spans the width of the unibody rails. The stock one ran into the 2.5L engine's oil pan. I cut the center out of it and replaced it with a section of 3/4" x 1.5" x 0.063" rectangular steel tubing, then braced it with another couple of pieces of tubing. It's way stiffer than the stock piece and only weighs a half a pound more.









Needs a prime and a coat of paint and it'll be good to go back on the car.
John V is offline   Reply With Quote
Old 01-19-2019, 04:33 PM   #129
AF
What ev's
 
Join Date: Apr 2005
Posts: 2,451
Iím sure I said this before or if I didnít I was thinking it, John youíre knowledge and abilities amaze me. Watching this thread with you building this car is incredible.
AF is offline   Reply With Quote
Old 01-19-2019, 04:40 PM   #130
Biggins
Crotchety
 
Join Date: Aug 2007
Carmudgeonly Ride: 13 FR-S, 16 CR-V
Posts: 821
As everyone has said, I cannot wait to see this thing in action!
Biggins is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:42 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Forums © 2003-2008, 'Mudgeon Enterprises - Site hosting by AYN & Associates, LLC