carmudgeons.com  

Go Back   carmudgeons.com > Automotive Forums > Technical Superiority

Reply
 
Thread Tools Display Modes
Old 05-18-2017, 02:32 PM   #11
lip277
The old cranky SOB....
 
Join Date: Oct 2003
Carmudgeonly Ride: several cars... way too many....
Location: Near Seattle
Posts: 3,823
Quote:
Originally Posted by rumatt View Post
Chevy S10?
Yeah
1983, 2.8L V6, long bed, 4 sp, 4x4. A slick little truck.
Too bad it had a carburetor and not FI. It was a California car so, that meant it had all sorts of smog baggage for not being able to adjust things that could adversely affect emissions. I think it got TBI in 1986. I just got tired of dealing with the carb on that thing.
__________________
Kevin


1970 2800CS - - 2001 740iL - - 2001 Yukon - - 2006 997.1
1968 Mustang GT Convertible - - 2003 Ford F250 PSD
lip277 is offline   Reply With Quote
Old 05-18-2017, 06:09 PM   #12
AF
What ev's
 
Join Date: Apr 2005
Posts: 1,976
Quote:
Originally Posted by John V View Post
Amazon had one in stock for seven bucks. So no big deal. It's just a bizarre fitting. Makes me wonder if the regulator on top of the air tank is not factory.

I typically go to McMaster or Grainger for this kind of stuff, but honestly Amazon is easier to search and I get free shipping, so...

and it comes in 2 days ... can't beat it
AF is offline   Reply With Quote
Old 05-18-2017, 11:54 PM   #13
clyde
Chief title editor
 
clyde's Avatar
 
Join Date: Oct 2003
Posts: 22,094
Quote:
Originally Posted by AF View Post



and it comes in 2 days ... can't beat it
I've found that 2 day Prime is not 2 day very often any more. But if you complain, they usually give you a free extra month of Prime. And it stacks up to a year. Ask me how I know.
__________________
OH NOES!!!!!1 MY CAR HAS T3H UND3R5T33R5555!!!!!!1oneone!!!!11

Team WTF?!
What are you gonna do?
clyde is offline   Reply With Quote
Old 05-18-2017, 11:59 PM   #14
ZBB
Relic
 
Join Date: Oct 2003
Carmudgeonly Ride: A very fast golf cart
Location: The Valley of the Sun
Posts: 10,874
Never had an problems with 2-day prime. Never late, and often next day instead...
__________________
ZBB
ZBB is online now   Reply With Quote
Old 05-19-2017, 06:56 AM   #15
John V
I only like old BMWs.
 
John V's Avatar
 
Join Date: Apr 2005
Carmudgeonly Ride: 987S, Ram, MS3, 330Ci, CX-5, RX-8
Location: Glenwood, MD
Posts: 11,937
Same here.
John V is offline   Reply With Quote
Old 05-19-2017, 08:20 AM   #16
rumatt
Mugwump
 
rumatt's Avatar
 
Join Date: Oct 2003
Carmudgeonly Ride: E46 330i
Location: NY
Posts: 15,359
Quote:
Originally Posted by ZBB View Post
Never had an problems with 2-day prime. Never late, and often next day instead...
Once or twice I've had it be late. But that's out of a shit load of orders.

Once I called and got a free month of prime. After that I decided it's not worth the time to call.
rumatt is offline   Reply With Quote
Old 05-19-2017, 08:32 AM   #17
Josh (PA)
Hello.
 
Josh (PA)'s Avatar
 
Join Date: Mar 2004
Carmudgeonly Ride: '03 325xiT, '11 135i C, '13 X5 n55
Location: Downingtown, PA
Posts: 2,731
I've noticed delays lately too. Around Christmas time, I was getting packages the same day I ordered. Now it seems that it is routinely in the 3 - 5 day range.
__________________
Josh (PA) -
'11 135i convertible
'13 X5 n55
'03 325 wagon
Josh (PA) is offline   Reply With Quote
Old 05-19-2017, 02:54 PM   #18
Plaz
 
Join Date: Oct 2003
Carmudgeonly Ride: '11 1M; '08 MCS; '02 325iT
Location: Churzee
Posts: 17,084
Quote:
Originally Posted by rumatt View Post
Once I called and got a free month of prime. After that I decided it's not worth the time to call.
__________________
2011 1M
Plaz is offline   Reply With Quote
Old 05-19-2017, 06:06 PM   #19
AF
What ev's
 
Join Date: Apr 2005
Posts: 1,976
Amazon has been great ... for the amount I order from them the problems have been very minimal and the few that they were they resolved better than 99% of other companies I have dealt with.

One time I had ordered a vizio surround sound speaker system below (or similar to that one) and it stopped connecting to the bluetooth subwoofer and surround speakers ... so in other words only the sound bar worked.

When I went to return it they ended up sending me a new one and told me to dispose of the old one on my own ... I couldn't believe it, the main sound bar worked so I ended up giving it away for someone to use.


https://www.amazon.com/VIZIO-SB3851-...surround+sound
AF is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:43 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Forums 2003-2008, 'Mudgeon Enterprises - Site hosting by AYN & Associates, LLC